Eclipse is running in a JRE, but a JDK is required

Eclipse 在安裝完Maven plugin,再啟動 Eclipse會出現下列錯誤:
Eclipse is running in a JRE, but a JDK is required
網路上找了一些資料,有一說法:
在 eclipse.ini 中加入下列資料
-vm
C:Program FilesJavajdk1.6.0_16binjavaw.exe
或是在環境變數中的 path 加入 jdk 的 path,
不過怎麼試還是有一樣的錯誤,後來在 eclipse.ini 中發現了一個參數,
-Dosgi.requiredJavaVersion=1.5
我就把他給砍了,再試試看,真是太神奇了,錯誤訊息不再出現了.

Related Posts

This Post Has 2 Comments

  1. -vm 後的javaw那個不用回車,不過發現另一個問題
    -vm 好像在 ini 裡有順序性,好像要放在前面,最近又開始出現這個問題,拿別人的ini回來就正常,
    內容是一樣,只是參數順序不同,所以有在想是不是那問題,下次再找時間試試

Comments are closed.